collapse collapse

* Search



* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?


Author Topic: Strange throttle problem  (Read 103 times)

CJ-vara

  • Tea Boy
  • *
  • Posts: 1
  • Varadero UK Rider
Strange throttle problem
« on: February 15, 2020, 02:19:26 PM »
Being having very strange  problems with my Varadero XL125 2007 (FI) My bike starts fine but will only idle if its up in 4k range and if it drops below it will stall and also the throttle is very laggy (if under 4k) i can open up wide throttle and have to wait 5-10 seconds to build back up the RPM so can ride off ..once in higher RPM seems fine, so have to keep revs up at all times. . ..The strange part is ive changed all that i think it could be...   
* New Throttle Body with the sensors and injectors that comes attached (TPS, IACV)
* New mini harnis (for injectors)
* New fuel pump
* New ECU
and its still the exact same , fuel pump primes fine .. no error codes on dash
Very strange i know ... its driving me nuts ..i just cant think what it could be .. it doesn't make sense 
Any help would be gratefully appreciated
Thank you

John J

  • Grease Monkey
  • **
  • Posts: 33
  • Varadero UK Rider
Re: Strange throttle problem
« Reply #1 on: February 15, 2020, 03:08:03 PM »
I've never worked on an XL125 but with any engine with this fault I would start with the basics. Spark plug cracked insulators can cause poor running at low revs but seem normal at high revs. A blocked fuel filter is also worth checking.

 


* Calendar

April 2020
Sun Mon Tue Wed Thu Fri Sat
1 2 3 4
5 6 7 8 [9] 10 11
12 13 14 15 16 17 18
19 20 21 22 23 24 25
26 27 28 29 30


SimplePortal 2.3.2 © 2008-2010, SimplePortal