collapse collapse

* Search



* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?


Author Topic: Varadero 125 'Bouncing' Speedo Problem  (Read 37 times)

ArcticPanda

  • Tea Boy
  • *
  • Posts: 1
  • Varadero UK Rider
Varadero 125 'Bouncing' Speedo Problem
« on: October 05, 2018, 12:37:54 PM »
I was riding home from work the other day, and all of a sudden, my speedo dropped to zero. Then a few seconds later it bounced back up and started swaying between 0mph and 40mph randomly.

I didn't do anything, and went to work the next day, and the speedo seemed fine, until about 20 minutes later when I was cruising steadily at 40mph, and it swayed around again (not quite as erratically).

Once I went back to less steady speeds and started braking, it seemed to stop swaying again.

Any ideas?

I have the 2007 Honda Varadero 125cc model

Taught2BeCautious

  • Tech
  • ****
  • Posts: 441
    • Varadero 125 Forum
Re: Varadero 125 'Bouncing' Speedo Problem
« Reply #1 on: October 06, 2018, 11:41:37 AM »
Earlier models have a mechanical / electronic speedo, later models are electronic only.

2007 was a 'changeover' year, so do you have a speedo drive cable coming from the left-hand side of the front wheel?

If so, check that the inner cable is well greased and hasn't started to come apart.  Also check the electrical connector block at the back of the speedo head and make sure both parts are clean and tight.

If not, just check the connector block as above.

Also, check that you have a good earth between battery and frame, battery and engine block, and frame and engine block.
HID Bi-Xenon Headlamps
Cyclone Alarm with Remote Start
DIY K&N Air Filter
Air Inlet Mod
DIY Hugger

 


* Calendar

October 2018
Sun Mon Tue Wed Thu Fri Sat
1 2 3 4 5 6
7 8 9 10 11 12 13
14 15 16 17 18 19 20
21 22 [23] 24 25 26 27
28 29 30 31


SimplePortal 2.3.2 © 2008-2010, SimplePortal